Mac OS

MacOS High Sierra is not fully supported by version 1.5.0. We advise to use version 1.4.0 that offers better compatibility with High Sierra


Download latest version

Open the downloaded file, the following window appears:

Drag the Softknobs Editor for Blofeld icon to the Applications folder
Run the editor directly from the applications folder